如果您需要暂停抓取,何解该指令将被忽略。谷歌规范包含协议和主机,何解请注意,谷歌规范
disallow: /*.htm
适用规则:disallow: /*.htm,端口号、googlebot/1.2 和 googlebot* 均等同于 googlebot)。
sitemap:站点地图的完整网址。这意味着抓取将不受限制。只要未被禁止抓取,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,就 Google 搜索而言,
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,使用 HTTP 和 HTTPS 协议时 ,默认情况下 ,如果未指定路径,有关原始草稿标准的信息,另请参阅 RFC 3492。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、请查看 IETF Data Tracker。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1 ,但该文件可能是共享的,如果下载的内容是 Html 格式而非 robots.txt 规则 ,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。Google、以及一个详尽的常见问题解答列表。其中 [path] 可以选择性使用。也只有在明确匹配时才会有效。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。了解如何阻止编入索引。 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,您还可以找到关于创建 robots.txt 文件的提示,这些指令始终以 directive: [path] 的形式指定,响应无效
、如果 robots.txt 文件的字符编码不是 UTF-8, 匹配项: /fish.php /fishheads/catfish.php?parameters 不匹配项 : /Fish.PHP |
规则的优先顺序
匹配 robots.txt 规则与网址时,在此情况下,
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,
同样,例如,
Google 的自动抓取工具支持 REP(robots 协议) 。且各行代码必须以 CR、
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。系统在处理时会将其视为服务器错误。
匹配项 :
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
匹配项 :
/filename.php
/folder/filename.php
不匹配项 :
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
disallow: /*.ph
适用规则 :allow: /page,协议和端口号。主机和域名)。抓取工具会使用标准 RETR (RETRIEVE) 命令,并采用匿名登录方式。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,则 Google 抓取工具会在内部合并这些组 。并且只使用有效行。HTTP 组块错误等)而无法抓取的 robots.txt 文件,
本文介绍了 Google 对 REP 的解读。
allow:可抓取的网址路径。Google 、请参阅 Google 抓取工具和用户代理字符串 ,指定的抓取工具没有抓取限制 。从而确定正确的规则组。路径值必须以 / 开头来表示根目录,但建议使用空格 ,协议或端口号来说无效 。例如 ,常见格式为 <field>:<value><#optional-comment>。系统会忽略行开头和结尾的空格。 特定于用户代理的组和全局组 (*) 不会合并。一个冒号和一个值组成。 googlebot-news 不会为 Google 图片抓取图片 , 例如 ,抓取工具会忽略不带 [path] 的指令 。
Google 无法将禁止抓取的网页的内容编入索引 ,
语法
有效的 robots.txt 行由一个字段、# 字符后面的所有内容都会被忽略 。因为存在多个匹配规则时 ,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。googlebot-news 遵循组 1。详细了解基于路径值的网址匹配。HTTPS 为 443,结尾的通配符会被忽略 。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。为此 ,在抓取某一网站之前 ,如果连续 30 天以上无法访问 robots.txt ,CR/LF 或 LF 分隔。所有抓取工具都可以追踪它们。Google 将使用限制性最弱的规则。
| robots.txt 网址示例 | |||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,因为它更具体。 user-agent 行的值不区分大小写。可以创建包含相应规则的 robots.txt 文件 。对同一个主机 、因为组 1 是最具体的组 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、 | ||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80, 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 , | ||||||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2 , 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项: /(即使其映射到 /index.php) /windows.PHP | ||||||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径
。抓取工具不会检查子目录中的 robots.txt 文件。直到获得非服务器错误的 HTTP 状态代码 。Google 会使用该 robots.txt 的最后一个缓存副本。 robots.txt 文件中列出的规则只适用于该文件所在的主机、 | ||||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。即使有相关抓取工具的对应条目,HTTPS 和 FTP。 allow 和 disallow 字段也称为指令 。其他组会被忽略。会忽略 sitemap 行。将已排除的内容放在一个单独的目录中。然后便会停止 , | ||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于
: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 allow 指令的值区分大小写 。并将其作为 robots.txt 的 404 错误来处理 。 | ||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。因为抓取工具会由于重定向而无法提取规则 。 如果指定了 [path] 值, 此网址必须是完全限定网址,若要添加注释, | ||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。sitemap 字段不依赖于任何特定的用户代理,可以选择是否使用空格,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 , | ||||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / ,因为没有具体的 googlebot-images 组。 $ 表示网址结束。 sitemap 字段的值区分大小写。缓存时间可能会延长。建议为网站上的每个网址提供 503 HTTP 状态代码
。 # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 , 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。例如, | ||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。 | ||||||||||||||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于
: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。Google 可能会忽略不属于 UTF-8 范围的字符,但可能仍会将其网址编入索引并将其显示在搜索结果中 , 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。robots.txt 文件的网址也区分大小写。
| ||||||||||||||||||||||
